30 NIGHT RETURNS | FREE SHIPPING

Perfectly Snug

Phone and WiFi Compatibility

App OS Minimum Requirements

The Perfectly Snug Controller App requires:

-Apple iOS 13 (You'll need an iPhone 6S, iPhone 6S Plus or iPhone SE or later)
-Android 4.4 or later

WiFi Network Compatibility

The Smart Topper is compatible with 2.4 GHz WiFi networks but not 5 GHz WiFi networks.  If you have a dual band 2.4 and 5 GHz router (this is common) the Smart Topper will operate fine.

More Info